Equifax processing delays

Incident Report for DDC Platforms Status Page

Resolved

This incident has been resolved.
Posted Feb 13, 2024 - 16:16 UTC

Investigating

We are currently investigating this issue.
Posted Feb 06, 2024 - 20:39 UTC