Login failure

Incident Report for DDC Platforms Status Page

Resolved

This incident has been resolved.
Posted Jun 20, 2024 - 20:14 UTC

Update

Service is restored. Users may have to clear their cache and cookies to be able to log in.
Posted Jun 20, 2024 - 20:14 UTC

Update

Users are currently unable to log in to the Minesight Platform. We are investigating the issue.
Posted Jun 20, 2024 - 19:48 UTC

Investigating

We are currently investigating this issue.
Posted Jun 20, 2024 - 19:47 UTC