Outage reported on dxp Frontend

Incident Report for DDC Platforms Status Page

Resolved

Service restored at 11:08, from detection to restoration 44 minutes
Posted Jun 16, 2025 - 17:10 UTC

Investigating

An outage has been detected on dxp Frontend. We are investigating the issue.
Posted Jun 16, 2025 - 16:37 UTC
This incident affected: nx.nutrien.com (Applications).