Outage reported on she Frontend

Incident Report for DDC Platforms Status Page

Resolved

Application is undergoing maintenance.
Posted Jun 24, 2025 - 21:56 UTC

Investigating

An outage has been detected on she Frontend. We are investigating the issue.
Posted Jun 24, 2025 - 21:54 UTC
This incident affected: homesafe.nutrien.com (Applications).