Outage reported on she Frontend

Incident Report for DDC Platforms Status Page

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 15:30 UTC

Investigating

An outage has been detected on she Frontend. We are investigating the issue.
Posted Aug 29, 2025 - 22:46 UTC
This incident affected: homesafe.nutrien.com (Applications).